POČTY, POČTY A ZASE POČTY….

Pro spoustu výpočtů potřebujeme znát počet buněk, kterých se to týká. A protože máme Excel, nemusíme nic počítat ručně 🙂 K dispozici máme několik šikovných funkcí a ty podle mě nejšikovnější vám dnes popíšu 🙂

Když potřebujeme zjistit celkový počet buněk v našem výběru, ve kterých je něco napsané použijeme funkci POČET2. Té je jedno, jestli jsou v buňce napsaná čísla nebo text, důležité je pro ni pouze to, že není prázdná.

Dále často používám funkci POČET, která zjistí pouze počet buněk, ve kterých je napsané číslo. Pokud tedy budete mít v buňce napsaný nějaký text nebo bude prázdná, bude ji ignorovat.

A když potřebujeme zjistit, kolik máme v tabulce prázdných buněk? Na to máme funkci COUNTBLANK.

Způsob zadání všech těchto funkcí je stejný, ukážeme si to na jednoduchém příkladu:

PŘÍKLAD: POTŘEBUJEME ZJISTIT POČET NEPRÁZDNÝCH BUNĚK, POČET PRÁZDNÝCH BUNĚK A POČET BUNĚK, VE KTERÝCH JSOU JEN ČÍSLA.

počet

V buňkách A2:A10 máme různá čísla, prázdné buňky i písmena. Počet neprázdných buněk, tedy těch, kde je něco napsané zjistíme funkcí POČET2. Do buňky C3 jen napíšu=POČET2( a vyberu myší oblast, ve které chci počet neprázdných buněk zjistit, potom uzavřu závorku. Celý vzorec tedy bude =POČET2(A2:A10).

Další dvě funkce se zadávají stejně. Pokud chci zjistit počet prázdných buněk, napíšu =COUNTBLANK(A2:A10) a pokud chci zjistit počet buněk, ve kterých jsou zadaná pouze čísla, napíšu do buňky vzorec =POČET(A2:A10).

Možná vás napadlo, že nám chybí funkce na zjištění počtu textových hodnot. A to máte pravdu 🙂 Takovou funkci zatím nemáme a proto pokud tento údaj potřebujeme, jednoduše si to dopočítáme 😉 =POČET2(A2:A10)-POČET(A2:A10)

počet2

Pokud neradi vzorce píšete, ale spíše vyplňujete, tak všechny tyto funkce najdete v nabídce Vzorce-Další funkce – Statistické. Vyberete funkci a do políčka označíte vybranou oblast.

Soubor s tímto příkladem si můžete stáhnout zde:

 

Další užitečné funkce a vychytávky se naučíte v mém onine kurzu Nejužitečnější nástroje Excelu, vstupte do něj tady: 

Napsat komentář