JAK ZVÁŽIT PRŮMĚR – SOUČIN.SKALÁRNÍ

SOUČIN.SKALÁRNÍ (SUMPRODUCT) je skvělá funkce, která umí mezi sebou vynásobit různé oblasti. S její pomocí můžeme zjistit, kolik jsou celkové tržby za všechny produkty, aniž byste museli manuálně násobit produkty s jejich cenou anebo nám třeba spočítá vážený průměr. Pojďme si funkci rovnou vysvětlit na příkladu. PŘÍKLAD: Máme 4 produkty, každý má jinou cenu a prodal se ho jiný počet kusů. Chceme zjistit, jaké jsou celkové tržby a také jaká je průměrná cena prodávaných produktů.

součin.skalární 1

Samozřejmě bychom teď mohli manuálně vynásobit cenu a počet prodaných kusů u každého produktu a to sečíst. Pokud ale použijeme funkci SOUČIN.SKALÁRNÍ budeme mít odpověď rychleji a bez zbytečného sloupce navíc.

Do buňky C9 si tedy vložíme naši funkci. Pokud rádi vyplňujete analogová okna, najdete ji na kartě Vzorce -Mat. a trig. Já budu ale funkci rovnou psát 🙂

součin.skalární 2

Napíšeme tedy =SOUČIN.SKALÁRNÍ(vybereme myší oblast, kde je zadaná cena ; vybereme myší oblast, kde je zadaný počet kusů), vzorec tedy bude vypadat =SOUČIN.SKALÁRNÍ(B2:B5;C2:C5). Tato funkce teď udělá, že vynásobí buňku B2 s buňkou C2, buňku B3 s buňkou C3 atd. a vše sečte. Hned tedy víme, že jsme vydělali 14 550 Kč 🙂

součin.skalární 3

POZOR!!! Vždy musíte vybrat oblast ve stejné velikosti, pokud bude jedna oblast mít méně řádků, nebude vám funkce fungovat.

Úplně stejně budeme postupovat, pokud budeme chtít zjistit průměrnou cenu produktu, tedy vážený aritmetický průměr. Kdybychom spočítali obyčejný aritmetický průměr pomocí funkce PRŮMĚR, nedostali bychom správný výsledek, protože každého produktu jsme prodali jiné množství. Proto je nutné vzít v úvahu právě důležitost, tedy váhu každého produktu.

Spočítáme si nejdříve podíl každého produktu na celkovém prodeji (viz. sloupec D) a nyní vložíme opět funkci SOUČIN. SKALÁRNÍ. Tentokrát vybereme opět pole s cenou produktů (B2:B5) a budeme ji násobit právě podílem, tedy vybereme pole D2:D5. Vzorec tedy bude vypadat

= SOUČIN.SKALÁRNÍ(B2:B5;D2:D5)

součin.skalární 4

Potvrdíme a průměrnou cenu produktu máme vypočítanou 🙂

součin.skalární 5

 Jak se vám funkce líbí? Využijete ji? Napište mi, budu ráda 🙂   Soubor s tímto příkladem si můžete opět stáhnout tady: soucin-skalarni  

Napsat komentář